Configuración de una WAN con HDLC y PPP

Posted on Actualizado enn

 

En esta entrada explicaré como configurar una WAN mediante 2 protocolos diferentes, PPP y HDLC


 

CONFIGURACIÓN HDLC

R1#conf terminal
R1(config)#ip route 192.168.2.0 255.255.255.0 Serial 2/0
R1(config)#interface loopback 1
R1(config-if)#ip address 192.168.1.1 255.255.255.0
R1(config-if)#exit
R1(config)#int Serial 2/0
R1(config-if)#ip address 1.1.1.1 255.255.255.252
R1(config-if)#encapsulation hdlc
R1(config-if)#no shutdown
R1(config-if)#end

R2#conf terminal
R2(config)#ip route 192.168.1.0 255.255.255.0 Serial 2/0
R2(config)#interface loopback 1
R2(config-if)#ip address 192.168.2.1 255.255.255.0
R2(config-if)#exit
R2(config)#int Serial 2/0
R2(config-if)#ip address 1.1.1.2 255.255.255.252
R2(config-if)#encapsulation hdlc
R2(config-if)#no shutdown
R2(config-if)#end

CONFIGURACIÓN PPP CON CHAP

R1#conf terminal
Router1(config)#hostname Router1
Router1(config)#username Router1 password cisco
Router1(config)#ip route 192.168.2.0 255.255.255.0 Serial 2/0
Router1(config-if)#end

Router1#conf terminal
Router1(config)#interface loopback 1
Router1(config-if)#ip address 192.168.1.1 255.255.255.0
Router1(config-if)#exit
Router1(config)#int Serial 2/0
Router1(config-if)#ip address 1.1.1.1 255.255.255.252
Router1(config-if)#encapsulation ppp
Router1(config-if)#ppp authentication chap
Router1(config-if)#no shutdown
Router1(config-if)#end


R2#conf terminal
Router2(config)#hostname Router2
Router2(config)#username Router2 password cisco
Router2(config)#ip route 192.168.1.0 255.255.255.0 Serial 2/0
Router2(config-if)#end

Router2#conf terminal
Router2(config)#interface loopback 1
Router2(config-if)#ip address 192.168.2.1 255.255.255.0
Router2(config-if)#exit
Router2(config)#int Serial 2/0
Router2(config-if)#ip address 1.1.1.2 255.255.255.252
Router2(config-if)#encapsulation ppp
Router2(config-if)#ppp authentication chap
Router2(config-if)#no shutdown
Router2(config-if)#end

CONFIGURACIÓN PPP CON PAP

R1#conf terminal
R1(config)#hostname Router1
Router1(config)#username Router1 password cisco
Router1(config)#ip route 192.168.2.0 255.255.255.0 Serial 2/0
Router1(config)#end
Router1#conf terminal
Router1#interface loopback 1
Router1(config-if)#ip address 192.168.1.1 255.255.255.0
Router1(config-if)#exit
Router1(config)#int Serial 2/0
Router1(config-if)#ip address 1.1.1.1 255.255.255.252
Router1(config-if)#encapsulation ppp
Router1(config-if)#ppp authentication pap
Router1(config-if)#ppp pap sent-username Router2 password cisco
Router1(config-if)#no shutdown
Router1(config-if)#end


R2#conf terminal
Router2(config)#hostname Router2
Router2(config)#username Router2 password cisco
Router2(config)#ip route 192.168.1.0 255.255.255.0 Serial 2/0
Router2(config-if)#end
Router2#conf terminal
Router2(config)#interface loopback 1
Router2(config-if)#ip address 192.168.2.1 255.255.255.0
Router2(config-if)#exit
Router2(config)#int Serial 2/0
Router2(config-if)#ip address 1.1.1.2 255.255.255.252
Router2(config-if)#encapsulation ppp 
Router2(config-if)#ppp authentication pap
Router1(config-if)#ppp pap sent-username Router1 password cisco
Router2(config-if)#no shutdown
Router2(config-if)#end

 

Fuentes: https://www.cisco.com/c/en/us/td/docs/ios-xml/ios/interface/configuration/15-s/ir-15-s-book/ir-cfg-ser-if.html#GUID-8C35C6E2-BC70-418C-B5D4-A01E3BF680CD

Fuente autenticacion PAP: https://www.cisco.com/c/en/us/support/docs/wan/point-to-point-protocol-ppp/10313-config-pap.html

AUTOR: David Perez Martorell davidperezmartorell@gmail.com

Nota: Si te sirvió lo que postié, te pido 2 segundos para contestar las encuestas que figuran abajo.

Gracias!

Anuncios

Responder

Introduce tus datos o haz clic en un icono para iniciar sesión:

Logo de WordPress.com

Estás comentando usando tu cuenta de WordPress.com. Cerrar sesión /  Cambiar )

Google+ photo

Estás comentando usando tu cuenta de Google+. Cerrar sesión /  Cambiar )

Imagen de Twitter

Estás comentando usando tu cuenta de Twitter. Cerrar sesión /  Cambiar )

Foto de Facebook

Estás comentando usando tu cuenta de Facebook. Cerrar sesión /  Cambiar )

Conectando a %s