Túneles GRE

Posted on Actualizado enn

En esta página recopilaré información acerca los túneles GRE.

Los túneles GRE son un  protocolo de encapsulación de propiedad de CISCO y sirve para crear túneles encapsulando un protocolo ( IPv4 / IPv6 ) dentro de otro.

Los túneles son conexiones dentro de las conexiones WAN. En este ejemplo, los routers se conectan entre ellos a través de la red publica 10.10.10.0, pero el túnel crea una conexión privada por las red 1.1.1.0. El protocolo GRE encapsulalos paquetes IP que deberían navegar por 10.10.10.0 con una etiqueta que los encapsula dentro de GRE.

Si no usáramos GRE, también navegarían a través del túnel pero los datos se enviarían en un modo NO seguro.

El comando para usar GRE es el siguiente:

insert_coma

tunnel mode gre ip

 

insert_topo

El protocolo GRE usa el 47. Sus funciones son la de encapsular los paquetes completos dentro de otro encapsulado. El MTU máximo es de 1676 bytes, ya que una trama es de 1500 y GRE necesita 24 bytes para componer su encapsulado.

 

Configuración de Router R1

interface Tunnel0
 ip address 1.1.1.1 255.255.255.0
 ip mtu 1400
 ip tcp adjust-mss 1360
 tunnel source 10.10.10.1
 tunnel destination 10.10.10.2

interface Loopback1
 ip address 2.2.2.2 255.255.255.0

interface Ethernet3/0
 ip address 10.10.10.1 255.255.255.0
 duplex full

ip route 3.3.3.0 255.255.255.0 1.1.1.2

 

Fuente: 

https://supportforums.cisco.com/t5/network-infrastructure-documents/how-to-configure-a-gre-tunnel/ta-p/3131970

Fuente encapsulado GRE: 

http://www.omnisecu.com/cisco-certified-network-associate-ccna/what-is-gre-generic-routing-encapsulation.php

AUTOR: David Perez Martorell davidperezmartorell@gmail.com

Nota: Si te sirvió lo que postié, te pido 2 segundos para contestar las encuestas que figuran abajo.

Gracias!

Anuncios

Responder

Introduce tus datos o haz clic en un icono para iniciar sesión:

Logo de WordPress.com

Estás comentando usando tu cuenta de WordPress.com. Cerrar sesión /  Cambiar )

Google+ photo

Estás comentando usando tu cuenta de Google+. Cerrar sesión /  Cambiar )

Imagen de Twitter

Estás comentando usando tu cuenta de Twitter. Cerrar sesión /  Cambiar )

Foto de Facebook

Estás comentando usando tu cuenta de Facebook. Cerrar sesión /  Cambiar )

Conectando a %s